Monday, October 11, 2010

Repair: MH-505 rescue and repair

If it hasn't happened to you yet, trust me, it will. Someday, at a time you least expect it. your beloved Monsoons will stop functioning.

Now, before you go and toss them, let's examine some of the more common failure points that you might experience, and some methods of repair that we can employ to keep your Monsoons up and running for years to come. I should also note that while I am specifically addressing the MH-505 speaker set, much of what follows applies to any and all Monsoon multimedia speaker sets.

Sub-woofer failure.

The single most common failure point of the MH-505s is the Sub-woofer. For reasons that I haven't yet seen an adequate explanation for, the construction of the sub-woofer is abysmally bad. Even when compared against inexpensive speaker sets from other manufacturers it just doesn't measure up. The speaker cone itself is actually good (VERY large magnet on that baby) but the power and control systems on the board are just plain bad.

I would personally be amazed to see a fully functional Monsoon sub-woofer. I suspect the only way anyone might see one at this point would be from an unboxed set discovered at the back of an electronics warehouse somewhere.

So what do you do when your Sub is dead or dying? At this point it is usually wise to take a step back and get some perspective on the situation. As I noted in my earlier review of the MH-505s, the real value in this speaker set is NOT the sub-woofer, but the flat panel surround speakers. So we want to keep these functional, even if it means we have to give up other parts. Trust me when I tell you this: The great sound these speakers have is NOT due to anything in the sub-woofer, it's the speakers alone that are giving you that great sound.

So, what do we need to get the speakers going again if the Sub is dead? Simple; We replace it. Now, you cannot get another Monsoon sub-woofer and frankly you don't want one. You need to find another, similar sub-woofer that will adequately replace the Monsoon one. How do we do this? We simply buy ANOTHER 5.1 speaker system and harvest the sub-woofer and controller from it and attach our existing speakers to it.

This is where it can get tricky fast. Not only do you have to ensure that the replacement sub-woofer has the correct connectors (both number and type) on it, but it's output has to be in the proper power band for the Monsoon speakers or you will either end up severely under driving them or you (even worse) will overpower and damage/destroy them.

So what is the current wattage of the existing MH-505 sub-woofer? If you refer back to my previous article, you will see the power rating as follows:

Amplifier power: 120 Wmax 85Wrms

The rating that we are really interested in the the RMS (Root Mean Square) rating, which is 85W for the MH-505s. Now, this does NOT mean that each individual satellite speak runs on 85 watts of power! The Monsoon PFTs actually use about 8 watts rms each, with the remaining 53 split between the center channel (13 watts) and the sub-woofer (40 watts). What we need to do is look for a replacement system that puts out similar power levels for the speakers and still has a respectable sub-woofer punch.

Right now there aren't many players left in the 5.1 PC speaker arena as more and more people are moving to laptops for their primary systems. However there are a few players left, and they make a couple systems that land right in the power band we need. (Although none are a perfect match.)

For right now I think the best option for harvesting a replacement sub-woofer are the Logitech X-540 speakers. As a whole this system puts out a bit less than the original Monsoon system with 7.4 watts RMS into each of the 4 satellite speakers, 15.2 watts center channel, and 25 watts into the sub-woofer. But of all the available systems it puts out the most power without going over the target number. This system also uses a separate control pot much like the MH-505's do. Some of the other mid-range 5.1 systems have the control pod merged into one of the speakers, which is not ideal.

The X-540's are currently running at a price point well under $100 USD and are carried by several major store chains including online computer sales powerhouse Newegg.com.

Once you have your X-540's home, unbox the power system, sub-woofer and control pot and leave the other 5 speakers in the box. (Or use them for other projects.) Then just remove your old Monsoon sub-woofer and control pot and replace them with the Logitech ones and voila! You are ready to rock and roll!


Damaged/Malfunctioning Control Pot


One of the other VERY common problems is the control pot. For reasons I don't understand Monsoon chose to use an 8 pin mini-DIN connector for the MH-505s. The issues with the 8 pin mini-DIN are the same as those in an old keyboard/mouse PS2 connector; Poor grounding and a weak connection point.

As such the DIN connector often develops problems entirely separate from the sub-woofer even if the sub-woofer is still functioning normally. Often it is simply the internal connections in the connector head that are weak, and replacing the connector head will fix these issues. Here follows basic info on the 8 pin mini-DIN connector:

Looking at the pin connector end-on with the two lone connectors at the bottom we see the following arrangement :

The pinout is as follows, starting at top left:

6 7 8
3 4 5
1 2

(NOTE: the connector is technically an 8 pin Mini-DIN. However there is a 9th "pin" which is the outer metal ring.)

The wires are coded as follows:

1)Black
2)White
3)Blue
4)Green
5)Yellow
6)Orange
7)Red
8)Brown
9)Dark Grey

You can purchase replacement 8 pin mini-din connectors online or at a local electronics parts supplier, although be aware it may be difficult to find.

Once you have your replacement connector, cut off the connector head from the control pot and strip the primary casing. Then identify and strip the appropriate wires and solder or crimp on the connections (depending on the connector type you bought) in the appropriate arrangement.

Also you can buy cables with the connector already on them. You then just have to splice the wires together and with a little luck and trial and error you should be able to get the pot working again.


Separated PFT Membrane.

Although less common, occasionally one or more of the PFT speaker membranes will separate from the rest of the speaker assembly causing either buzzing/unwanted sound or no sound at all. At this point you have two choices; You can either search craigslist and ebay for a replacement PFT speaker, or you can repair your PFT! The instructions to repair the PFT are rather involved and NOT for the faint-of-heart, but it CAN be done!
I should note that the instructions below are actually for the 2.1 Monsoon systems with exposed connectors. The MH-505s have no exposed connector rivets or screws, you have to pop the front cover off first to gain access to them.
Here is a post from ATPM.com by "shmoke" with an excellent step-by-step on repairing your PFT.(With minor spelling and grammatical corrections by myself.)

shmoke · April 08, 2006 - 00:14 EST #90
...I knew that I couldn't be the only one with this buzzing problem with these Monsoons. But I do appear to be the only person to find and repair the cause of the noise, and share my results.

It was so bad that I was committed to either repair them or throw them away. It was just as I described in my previous post: a raspy, crunchy buzz that follows the mid-range material. It was worse at higher volumes and with certain voices and instruments, but was basically present all time to some degree. It only appeared in the right speaker and stayed with that speaker no matter which channel it was hooked up to - eliminating any fault with the electronics or volume control puck.

I tore straight into the heart of the speaker without fear. I used a large drill (1/4") to mill the rivets down on the wedged side, not all the way through, just enough to release the head. I removed the stand by drilling those rivets too so that I was just holding the flat panel with the cord dangling. I remember that those rivets were larger than the others and tougher to drill. This releases the stand and rear cover from the sandwich and gives you access to the rear of the panel, and you can begin drilling all the small brass rivets that hold it all together.

Be careful after you've milled all the brass rivets and begin to push them out because when you get down to the last ones the sandwich is going to try to fly apart with great force and reorient itself quickly to relieve magnetic tension. It could damage the membrane if you don't control this. If you have a second set of helping hands you'll be more prepared than I was.

The membrane is one with the rear panel and the front panel can be completely removed and inspected for the plating damage that causes the buzz. But the rear panel is the more likely culprit since the front magnets are covered with a thin black felt material and don't have direct contact with the membrane like the rear magnets do.

So you've decided to peel the membrane off? Okay. Start at the bottom and peel it off carefully taking great care to keep from stretching or tearing the thin plastic. Heat may help but I didn't use any. If you screw up here just throw it in the trash and check eBay for a replacement.

Yes it is like Mylar, just not as strong. This membrane is very fragile and is embossed with a wavy ribbon pattern that looks like it plays some role in the sound of the speaker.

Peel that off and lay it carefully aside. The wiring attaches to the membrane at the bottom. Now you're holding the rear array and the magnet damage (if you have any) should be clearly visible. In my case it was plating on the magnets that was chipping and peeling and rubbing the membrane. I cleaned off the bad plating with a micro-screwdriver and re-assembled.

I reapplied the membrane by placing wide, glossy scotch tape in long strips around the four sides of the membrane with a half-inch reveal. I placed the membrane on the rear array and evenly stretched the tape over the sides of the steel panel until the membrane was as tight as a snare drum.

I made sure that the membrane felt and sounded approximately as it did before I removed it. I must have done it right because the rebuilt driver sounds almost better than the other one!

I reassembled the sandwich with small socket cap bolts and nuts. I think I used 4-40 or 5-40 x 1/4" bolts and nuts to replace the small rivets and 10-32 x 3/8" bolts and nuts to re-attach the stand.

I couldn't be happier with the results. I've still got my monsoons and I'm back in business!

Before you dive in, you need to make darn sure that the buzz is coming from the driver and not from the electronics. If you swap the speakers between the left and right amplifier jacks, does the noise stay with the speaker in question?

The membrane is finer than Mylar and is quite fragile. There is a convoluted texture embossed into the ribbon that looks like it contributes to the sound of the speaker. The wiring is soldered to pads on the membrane at the bottom of the driver near the stand.

The stand comes off first before the rear grill can be removed. You have to take the stand apart far enough to un-tread the wire from the base before you begin. Pry off the front grill and drill the rivets that attach the stand to the driver. With the stand, the plastic trim and the grills removed, you are holding the small, thin sandwich and the surgery can begin.

Drill all of the small brass rivets from the back side (the wedged side) and push them out through the front to remove. I used a 1/4" drill bit and I just milled down the rivets just enough that they could be pushed through the holes.

Take extra care here. When the last few rivets are popped out, the sandwich is going to try to fly apart in your hands and reorient themselves quickly to relieve magnetic tension between the front and rear arrays. If this event is not controlled, the membrane can be damaged and there will be no need to continue.

Inspect the front array. There is a black felt covering over the magnets on the front array so it's doubtful that the front magnets are the source of the buzzing. If there's nothing wrong with the front array, you're probably going to wind up peeling the membrane off to access the rear magnets.

Peel the membrane very slowly starting from the bottom, near the speaker wires, taking great care to keep from stretching or tearing the delicate plastic. Heat may help but I didn't use any. Set the membrane aside in a safe place.

Now you're looking at the rear magnet array and the damage should be very obvious. In my case, the plating on the magnets was cracked and peeling off. The plating was thick enough to interfere with the membrane and cause the buzzing at certain frequencies and volume levels. I picked the loose plating off with a micro screwdriver and cleaned up the array with compressed air.

Now for reassembly. Put four lengths of wide, glossy scotch tape around the perimeter of the membrane with a half-inch reveal and lay the membrane over the rear array, taking care to match the holes in the membrane with those in the rear array. Pull the tape over the edges, starting with the top and bottom. Then evenly stretch and secure the membrane across the sides.

As you apply the membrane, do your best to match the original tension and feel to maintain the proper voice of the driver. If you have a wrinkle or a sag, it will surely impact the sound. I got mine right on the first try, and it sounds almost better than the other driver.

Reassemble the sandwich with 4-40 or 5-40 x 1/4 or 5/16 inch length, socket cap bolts and nuts. Reattach the stand and rear grill with 10-32 x 3/8 or 1/2 inch length, socket cap bolts and nuts. Some trimming of the plastic frame will be necessary to clear the extra size of bolts instead of rivets.

If you've done it right...you'll be back in business!
And there you have it, full instructions on repairing a PFT. As always, follow instructions "At Your Own Risk". I cannot be held responsible if your fumblefinger the instructions and destroy your PFT in the process.

Broken Wires

This is probably the cheapest and easiest fix of all, however it can be tricky. If your wire is broken well down the cord then just grab some wire crimp connectors from your local hardware/electronics store and attach them, done.

If the break is near the speaker or the wires are pulled out of the speaker you have a trickier problem on your hands. If you follow the instructions above you will find how to open the speakers up. Once inside determine if there is any wire left inside or if it has been pulled free of the speaker entirely. If there is any wire left attempt the same repair as you would with a normal cord break. If however the wire is entirely torn free there is no repair possible as the wire is attached directly to the delicate PFT membrane and the tearing has likely destroyed it. If this is what has happened that speaker is dead, start searching ebay for another. (If anyone has a repair option for this type of damage please let me know and I will amend this post.)

That covers most of the common repairs that you may have to perform on your MH-505s. If anyone has anything else to add that may make this article more complete, please feel free to comment or email me and I will update as needed.

25 comments:

Anonymous said...

Hi, cool to see you started up with this blog again. The problem with your subwoofer solution is that the new subwoofer will have a crossover setting of like 80hz, while the monsoon speakers have a special crossover of 200hz on the subwoofer, because the monsoon speakers do not reproduce sound well below 200hz, unlike traditional cone driven speakers... basically you lose the frequency range between 80hz-200hz and it sounds quite bad when I have tried this solution. Don't you feel like there is a hole in your bass frequency when you set your speakers up this way?

Or do you think the monsoon speakers can be driven ok between 80hz-200hz. It was my previous understanding that they couldn't really produce sound at those frequencies, but maybe they just can't produce it to the satisfaction of the old monsoon engineers?

My subwoofer died four years ago and I have never gotten the set working again. I even went inside it and replaced the bridge rectifier and a bunch of capacitors and stuff that seemed like they could be causing the problem, lol. But when I tried just plugging the monsoons into another computer speakers subwoofer it didn't sound right, like way out of balance or like there was a hole in the sound, and I thought this was because of the crossover.

Anonymous said...

Hmmm... I guess the crossover doesn't work quite as simply as I thought, I tested these again with a subwoofer from an old computer speakers set and used a tone generator to test the frequency response and although yes the monsoon speakers don't really produce anything below around 150 or 200hz, the subwoofer itself fills in on tones all the way up to 300 or 400 hz, so there is a reasonably large crossover and hopefully with a good balance between subwoofer and speaker balance I can find a way to make these sound great again. I'll play around with it and get back to you, if I get my old speakers back working again that I loved so much you will really be my hero, bro. Hehe.

4saken said...

Stupid question, but how the heck do you get into the case?

My Monsoons have been crackling badly for some time. I'm thinking it's the DIN connector.

congaman said...

Mine are popping and crackling too. I can feel the din feels loose in the plug. I may try to replace this before I trash them.

Anonymous said...

The sub on my Planar Media 9s just has screws on the back that you can take out and then open it up, then the power to the subwoofer coil (or whatever) is connected with a couple of plugs and you kind of have to squeeze your fingers in there and get hold of the plugs and undo them to take the plate off after you get the screws on the back of the sub out.

I couldn't get my PM9 speakers to sound good with the Creative speakers sub that I have, but I think that might just be because the sub is too shit and so it creates an incongruity in the sound.

Anonymous said...

I would like to have an updated option for replacing the puck and subwoofer; the Logitech X 540's are no longer available except on e-bay(no thanks) and Amazon wants $600(no way)for a set.

LaValls said...

Hi, As an owner of a set of mh505's, I was delighted to see your posts. So far everything works except my control pod makes static when I turn the volume knob. The "fader and Bass knobs" work fine.
Anyway thnks for your info.....
Mark

LaValls said...

Have any of you heard of any company thinking of building this design again??? Seems to me that 9 years later these are still the best sounding speakers on the market and I would think someone would produce them again????
Who owns the patents???

Steven Sun said...

My mh-505s emit a continuous tone when the control pod is plugged in. If I leave them unplugged for a while, they will work for a day or so before they start humming again.

Does anyone know what likely issue is? I'm about to tear open the sub, but I have no idea where to start.

BigRick said...

Found this blog.. Awesome. I've had mine since 2004. Sub still works fine. But the control pod causes the crackling noise. It's been like that for years. Sometimes it disappears for a while then it comes back. As long as the pod is off then I get no problems.. lol
any who, if anyone would like to sell their pod give me a shout.
I'm not sure about replacing the adapter.

Steven Sun said...

BigRick, in looking for replacement parts for my set I found this: http://azsurplus.com/index.php?main_page=product_info&cPath=18_83&products_id=642

Might be worth a shot.
Steve

sakman said...

Hi!

I stumbled onto this blog while trying to find a solution to my slowly dying MH-505 speaker set.

Over the last couple of weeks, the sound stared fading in and out and within the last couple of days they were popping and cracking all the time (except when muted).

I tried bridging the pins that I thought were the black and white wires according to the above diagram but it didn't work. I disassembled my controller and found out that the black and white wires were assigned to different pins. In my unit, the pins are #6 and #8.

I stuck a 22ga solid wire jumper on those pins on the back of the subwoofer and now I've got sound.

I took pics of the internals of my controller and I've written down all the visible values. When I get a chance, I'll upload the pics somewhere and post a link. Maybe someone can build replacement controllers. But you really don't need the controller if you jump the black and white pins.

Thanks for helping me get my Monsoon back working!

sakman said...

I uploaded some pics of my MH-505 controller.

MH-505 male plug with an overlay of the wire colors as I found them on my controller. Note the outer metal shield connects to the dark grey wire. http://i124.photobucket.com/albums/p40/sak55/Monsoon/MiniDIN8MalePlugColor.jpg

MH-505 Jumper to enable sound without controller: http://i124.photobucket.com/albums/p40/sak55/Monsoon/Jumper22AWG.jpg

MH-505 Circuit Board Connector with the wires: http://i124.photobucket.com/albums/p40/sak55/Monsoon/BoardWireConnector.jpg

MH-505 Top of the circuit board: http://i124.photobucket.com/albums/p40/sak55/Monsoon/Top.jpg

MH-505 Bottom of the circuit board: http://i124.photobucket.com/albums/p40/sak55/Monsoon/Bottom.jpg

I'll post the values of all the components found on the circuit board later.

sakman said...

MH-505 Controller Parts List: http://i124.photobucket.com/albums/p40/sak55/Monsoon/MH-505ControllerPartsList.jpg

MH-505 Controller Top/Bottom Overlay: http://i124.photobucket.com/albums/p40/sak55/Monsoon/Overlay.gif

I'll make a schematic of the circuit when I find more free time.

sakman said...

Disguised Jumper Mini DIN 8 plug: http://i124.photobucket.com/albums/p40/sak55/Monsoon/JumperMiniDIN8.jpg

low_profile said...

I'm wondering if you could give me help on locating the small speaker stands located at the bottom of the flat panel speakers of a MM 2000 4.1 system?

Any help would be appreciated.

Thanks.

Stefan said...

So, my wife has had a set of Monsoon MH-500 speakers for more than 13 years. These thin speakers and accompanying sub-woofer deliver sound quality comparable to high-end Bose speakers, but they started popping and crackling over the last year or so. After listing to music and movies on some cheap, unshielded pieces of crap that hum and emit high-pitched whining whenever there is Wi-Fi traffic, I decided fixing the Monsoons was a priority.

There is a "standby" mode that autodetects a signal, and then turns the amp on when one is present. This circuitry was getting flakey and causing the pops and crackles, so after pulling the sub-woofer apart, tracing things around from the indicator LED, and googling some datasheets it amounted to simply shorting the "Stand-by/Mute" pin 11 of the TDA1516CQ to Vp pin 10 (Supply Voltage). This forces Stand-by mode off and now there is no annoying lag when starting music, no annoying shut-off for low-volume music, and most importantly no popping and crackling.

Of course, while trying to show-off the fix to my wife by shorting the pins with a DMM probe, I accidentally touched one of the power rails and blew up an 8-pin DIP IC. This was a TI-555 timer chip, so I went digging in my box of logic circuits and components from college, found a Motorola version (LM555CN) de-soldered the blown one, soldered in the new one, then did a crappy jumper wire solder job and Voila!! So stoked I just had to share.

facebook post with pics here: https://www.facebook.com/stefangriebel/posts/10152218322469587?stream_ref=10

Anonymous said...

Hi There, I have the Monsoon MH 500 and love em. Any idea where to find a new sound and cord puck? ty mzshannie@yahoo

Anonymous said...

how can i use my mh 500 without the puck?

Steven Williams said...

Buzzing and cracking noise. How do I fix this? The puck was bad so I am using another connector wire.

Steve Williams
solotworacer@gmail.com

Anonymous said...

Ive a MH500 since 2000. On 2014, the subwoofer started to do a strange behavior. Its like being running out of power, or something related. I've decide to open it and look for some solutions. Ive taken appart the subwoofer speaker and tested it on an external amplifier and it works well, but when connected to the original system, it seems to be like being interfered or running out of power. I dont know how to explain this so well, but im doing my best. The satellite speaker works well always, even at minium or maximum output, but the subwoofer does not. Its like using a 5 watt subwoofer instead of 40W that suposed to be.
Any ideas i would be very glad to hear
Thanks in advance

My email is martinezfranciscosi36@gmail if someone wants to share some useful info

When ive foubd this page, some kind of happy feelibg about hope took my entre body. I really love this speakers and i would do everything to make it works again

Anonymous said...

I cant believe i threw out the controller thinking i had misplaced the speakers during a move.
emptied the storage shed a few month ago and there they were.
going to try the bridging pin for now . fingers crossed.

Grumpy Doc said...

I am having problems with the unit that controls the volume and on/off button. I have opened it up - on problem just 2 Phillips screw and used a sound cleaning solution around the wheel contact that adjusts the sound volume. It works well for a day or two and then becomes a problem again - only working on one channel.

Does anyone know where I might get a new or used functioning small control unit ?

Grumpy Doc

Tom said...

I have an MM 700 that I have always loved! The 3.5mm jack that plugs into the computer is dead after I spliced it open. I was right that the wires were frayed or had separated. But now I need to know which wire goes where. It appears there are three places the wires need to be soldered on to the jack,but not sure. Anyone have info on this? Much thanks in advance if so!!

sandouble said...

I have the MH-505 5.1 system as well. about 8 years ago, i lost my system due to a power surge. The AC adapter was damaged and the unit would not power up. I read some of the fixes about using another systems sub and power supply, but never actually tried it. I kept my eye out for a new power supply of over the years and actually grabbed one from Ebay. It was actually for a Monitor Audio iDeck model SY-13300A, which is a sound system that docks to an iPhone. The Power supply was IDENTICAL, right down to the manufacturing date. I got it for $30. So, I plugged it in, an my unit powered up just fine. I set my PC to the correct sound card, but no sound from any of the speakers. I plugged headphones into the control pot and have perfect sound. I opened up the sub to check out the circuit board, but couldn't find anything out of the ordinary(one capacitor near the DC input looked a little brown, but not blown.) The 4 amp fuse was still OK. I was so excited to get this thing working again. If anyone has any ideas, please post. Thanks!